Click here to login to Esendex Connect.

Esendex Connect Service Degradation

Major incident Esendex UK Customer Frontend Customer APIs Brochure Sites and Documentation Message Sending
2025-10-29 16:11 GMT · 6 hours, 28 minutes

Updates

Resolved

We found the root of the issue and we have fixed it.

October 29, 2025 · 22:39 GMT
Issue

We are currently experiencing some temporary technical issues which may be affecting some of our customers’ ability to send or receive messages; in some cases this may also include gaining access to any of our services.

This is related to the Microsoft Azure global outage

We’re sorry that this is happening. Thank you for your continued patience and support while we work to resolve this.

October 29, 2025 · 16:11 GMT

← Back