Click here to login to Esendex Connect.

Message history incident

Minor incident Esendex UK Customer Frontend Customer APIs
2025-05-15 04:30 BST · 2 hours, 7 minutes

Updates

Resolved

The incident is resolved, and new messages can now be read in the message history

May 15, 2025 · 06:37 BST
Issue

We are investigating an issue with being able to read message history. Message sending is unaffected.

May 15, 2025 · 06:30 BST

← Back